Uutiset:

Kirjoittaja Aihe: TalologgerPi:n uudestaanpystytys  (Luettu 1878 kertaa)

Poissa Ahwell

  • Nuorempi jäsen
  • **
  • Viestejä: 29
  • Maalämpöfoorumi
TalologgerPi:n uudestaanpystytys
« : 26.02.23 - klo:18:17 »
Kosahti Raspista muistikortti ja data katosi taivaan tuuliin.
Talologgerin lataus ei toimi ja en saa kehittäjää kiinni.
Pari vuotta sitten oli sama tilanne. Silloin homma ratkesi latausserverin päivityksellä.

Onko kellään mitään ideaa miten saisi syteemin pystytettyä uudelleen?

Nimimerkki: "olisi pitänyt tehdä BU, mutta jostain syystä kortin kopiointi ei toiminut"
Pumppu: IVT HE E9, 300l käyttövesivaraaja, lämpimän käyttöveden kierto.
Kaivo: 210m.
Talo: 1000m3 kivitalo rv. 2002. Uusimaa.
IV: Vallox 145 MV
Kulutus 9MWh/a

Poissa jolla

  • Täysjäsen
  • ***
  • Viestejä: 131
  • Maalämpöfoorumi
    • mittauksia
Vs: TalologgerPi:n uudestaanpystytys
« Vastaus #1 : 27.02.23 - klo:21:06 »
kyllä se toimii, hiirellä llikkaa niin sekunnissa on ladattu

Poissa Ahwell

  • Nuorempi jäsen
  • **
  • Viestejä: 29
  • Maalämpöfoorumi
Vs: TalologgerPi:n uudestaanpystytys
« Vastaus #2 : 28.02.23 - klo:10:38 »
kyllä se toimii, hiirellä llikkaa niin sekunnissa on ladattu

Tarkoitat varmaan "tulee sekunnissa" tuota asennusscriptiä?

 wget -O install_taloLoggerPi.py http://olammi.iki.fi/sw/taloLoggerPi/install_taloLoggerPi.py

Varsinainen asennus pitäisi kestää 15 minuuttia, mutta tulee alla olevat herjat:

E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
ERROR: Missing required package: daemontools
ERROR: Missing required package: python-mysqldb
ERROR: Missing required package: python-sqlite
ERROR: Missing required package: python-psycopg2
ERROR: Missing required package: apache2
ERROR: Missing required package: php
ERROR: Missing required package: php-mysql
ERROR: Missing required package: php-sqlite3
ERROR: Missing required package: php-pgsql
ERROR: Missing required package: php-gd
ERROR: Missing required package: sqlite3
ERROR: Missing required package: owfs
ERROR: Missing required package: digitemp
ERROR: Missing required package: rrdtool
ERROR: Missing required package: python-oauth
ERROR: Missing required package: daemontools-run
ERROR: Missing required package: insserv
ERROR: Missing required package: python-paho-mqtt
Terminating install process due to missing packages.
Pumppu: IVT HE E9, 300l käyttövesivaraaja, lämpimän käyttöveden kierto.
Kaivo: 210m.
Talo: 1000m3 kivitalo rv. 2002. Uusimaa.
IV: Vallox 145 MV
Kulutus 9MWh/a

Poissa jolla

  • Täysjäsen
  • ***
  • Viestejä: 131
  • Maalämpöfoorumi
    • mittauksia
Vs: TalologgerPi:n uudestaanpystytys
« Vastaus #3 : 28.02.23 - klo:13:58 »
näin tekee uudemmilla distroilla

aja ensin
sudo apt install python2
sudo apt install curl
curl https://bootstrap.pypa.io/pip/2.7/get-pip.py --output get-pip.py
sudo python2 get-pip.py

pip2 --version

suattaapi auttaa

Poissa Ahwell

  • Nuorempi jäsen
  • **
  • Viestejä: 29
  • Maalämpöfoorumi
Vs: TalologgerPi:n uudestaanpystytys
« Vastaus #4 : 28.02.23 - klo:20:50 »
näin tekee uudemmilla distroilla

aja ensin
sudo apt install python2
sudo apt install curl
curl https://bootstrap.pypa.io/pip/2.7/get-pip.py --output get-pip.py
sudo python2 get-pip.py

pip2 --version

suattaapi auttaa

Eipä tuntunut auttavan. Vai näetkö tässä jotain tehdyksi väärin?

pi@raspberrypi:~ $ sudo apt install python2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
python2 is already the newest version (2.7.16-1).
python2 set to manually installed.
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libwebkit2gtk-4.0-37 : Depends: libjavascriptcoregtk-4.0-18 (= 2.36.7-1~deb10u1+rpi1) but 2.38.5-1~deb10u1+rpi1 is to be installed
                        Recommends: gstreamer1.0-gl but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
pi@raspberrypi:~ $ sudo apt install curl
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 curl : Depends: libcurl4 (= 7.64.0-4+deb10u5) but 7.64.0-4+deb10u4 is to be installed
 libwebkit2gtk-4.0-37 : Depends: libjavascriptcoregtk-4.0-18 (= 2.36.7-1~deb10u1+rpi1) but 2.38.5-1~deb10u1+rpi1 is to be installed
                        Recommends: gstreamer1.0-gl but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
pi@raspberrypi:~ $ curl https://bootstrap.pypa.io/pip/2.7/get-pip.py --output get-pip.py
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 1863k  100 1863k    0     0   639k      0  0:00:02  0:00:02 --:--:--  639k
pi@raspberrypi:~ $ sudo python2 get-pip.py
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting pip<21.0
  Downloading pip-20.3.4-py2.py3-none-any.whl (1.5 MB)
     |████████████████████████████████| 1.5 MB 19 kB/s
Installing collected packages: pip
  Attempting uninstall: pip
    Found existing installation: pip 18.1
    Uninstalling pip-18.1:
      Successfully uninstalled pip-18.1
Successfully installed pip-20.3.4
pi@raspberrypi:~ $ pip2 --version
pip 20.3.4 from /usr/local/lib/python2.7/dist-packages/pip (python 2.7)
pi@raspberrypi:~ $ wget -O install_taloLoggerPi.py http://olammi.iki.fi/sw/taloLoggerPi/install_taloLoggerPi.py
--2023-02-28 20:22:58--  http://olammi.iki.fi/sw/taloLoggerPi/install_taloLoggerPi.py
Resolving olammi.iki.fi (olammi.iki.fi)... 217.112.242.173
Connecting to olammi.iki.fi (olammi.iki.fi)|217.112.242.173|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 27035 (26K) [text/x-python]
Saving to: ‘install_taloLoggerPi.py’

install_taloLoggerP 100%[===================>]  26.40K  --.-KB/s    in 0.1s   

2023-02-28 20:22:58 (192 KB/s) - ‘install_taloLoggerPi.py’ saved [27035/27035]

pi@raspberrypi:~ $ chmod 755 install_taloLoggerPi.py
pi@raspberrypi:~ $ sudo ./install_taloLoggerPi.py
*********  taloLoggerPi - install_taloLoggerPi.py - v1.1h  ********************

Determining installed versions...
Retrieving versions from the network...
This process will install:
    taloLoggerPi:    v1.1h
    taloLogger:      v1.7k
    taloLoggerGraph: v1.2d

Proceed to install (Y/n)y
Installing taloLoggerPi...
Installing necessary apt-get -packages...
Updating apt-get database...
Get:1 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
Get:2 http://archive.raspberrypi.org/debian buster InRelease [32.6 kB]
Get:3 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages [13.0 MB]
Get:4 http://archive.raspberrypi.org/debian buster/main armhf Packages [392 kB]
Fetched 13.5 MB in 31s (432 kB/s)                                             
Reading package lists... Done
  Installing package daemontools...
Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libwebkit2gtk-4.0-37 : Depends: libjavascriptcoregtk-4.0-18 (= 2.36.7-1~deb10u1+rpi1) but 2.38.5-1~deb10u1+rpi1 is to be installed
                        Recommends: gstreamer1.0-gl but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
  Package python-serial already installed. Skipping...
  Package python-pil:armhf already installed. Skipping...
  Installing package python-mysqldb...
Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libwebkit2gtk-4.0-37 : Depends: libjavascriptcoregtk-4.0-18 (= 2.36.7-1~deb10u1+rpi1) but 2.38.5-1~deb10u1+rpi1 is to be installed
                        Recommends: gstreamer1.0-gl but it is not going to be installed

**********************Karsittu välistä pois*************************************************

E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
  Installing package python-paho-mqtt...
Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libwebkit2gtk-4.0-37 : Depends: libjavascriptcoregtk-4.0-18 (= 2.36.7-1~deb10u1+rpi1) but 2.38.5-1~deb10u1+rpi1 is to be installed
                        Recommends: gstreamer1.0-gl but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
  ERROR: Missing required package: daemontools
  ERROR: Missing required package: python-mysqldb
  ERROR: Missing required package: python-sqlite
  ERROR: Missing required package: python-psycopg2
  ERROR: Missing required package: apache2
  ERROR: Missing required package: php
  ERROR: Missing required package: php-mysql
  ERROR: Missing required package: php-sqlite3
  ERROR: Missing required package: php-pgsql
  ERROR: Missing required package: php-gd
  ERROR: Missing required package: sqlite3
  ERROR: Missing required package: owfs
  ERROR: Missing required package: digitemp
  ERROR: Missing required package: rrdtool
  ERROR: Missing required package: python-oauth
  ERROR: Missing required package: daemontools-run
  ERROR: Missing required package: insserv
  ERROR: Missing required package: python-paho-mqtt
Terminating install process due to missing packages.
pi@raspberrypi:~ $


Olisiko lisää ideoita?

Tuolla olisi joku image, mutta kun en osaa asentaa kortille. Osaisiko joku auttaa asiassa?
https://hub.docker.com/r/brikkney/rpi-talologger/

Pumppu: IVT HE E9, 300l käyttövesivaraaja, lämpimän käyttöveden kierto.
Kaivo: 210m.
Talo: 1000m3 kivitalo rv. 2002. Uusimaa.
IV: Vallox 145 MV
Kulutus 9MWh/a

Poissa Timo Karhu

  • Konkari
  • *****
  • Viestejä: 843
  • Turisti.
    • F1145 Säädöt: käyrä 3(+2), am -180, lisäys -600, keruu AUTO, kv AUTO, lj 35%, lt-pyynti 21,5C kerroin 4
Vs: TalologgerPi:n uudestaanpystytys
« Vastaus #5 : 28.02.23 - klo:21:39 »
Tuo lienee docker levykuva. Ajoitko tuon apt:n ehdottaman korjauksen?
Koodia: [Valitse]
sudo apt --fix-broken install
RMT: -58/169m2/650m3/27->14,5MWh/a/1-3hlö/kellari 16C
MLP: 177m kaivo / F1145-10+VPB200+UKV100 / C33(1)-C22(11)-C21(2)-C11(5), Volcano Mini EC.
IV: LTR-3 EDW / Sabiana Fly 4
S: 2-aika/m.aik./s-kiuas, 29m2-latt.lämm

Poissa jolla

  • Täysjäsen
  • ***
  • Viestejä: 131
  • Maalämpöfoorumi
    • mittauksia
Vs: TalologgerPi:n uudestaanpystytys
« Vastaus #6 : 28.02.23 - klo:23:08 »
niinpä siinä raspin tapauksessa jokin mättää
olen tuolla perusreseptillä ajanut bananapi'hin ja rockpi4a sekä rockpi4b hen

katselen kun ehdin mielenkiinnosta meneekö enää ollenkaan raspiin

Poissa jolla

  • Täysjäsen
  • ***
  • Viestejä: 131
  • Maalämpöfoorumi
    • mittauksia
Vs: TalologgerPi:n uudestaanpystytys
« Vastaus #7 : 01.03.23 - klo:09:23 »
kokeilin raspilla (rpi4) eri softilla, siis valmiina saatavilla ja näyttää että 5.10 on vimonen mikä toimii ilman akrobatiaa ja sukanvaihtoja ja päälläseisomista
Linux raspberrypi 5.10.103-v7l+ #1529 SMP Tue Mar 8 12:24:00 GMT 2022 armv7l GNU/Linux
täältä
https://www.raspberrypi.com/software/operating-systems/

Raspberry Pi OS Lite (Legacy)
Release date: February 21st 2023
System: 32-bit

sudo su
apt update
apt upgrade
wget -O install_taloLoggerPi.py http://olammi.iki.fi/sw/taloLoggerPi/install_taloLoggerPi.py
chmod 755 install_taloLoggerPi.py
./install_taloLoggerPi.py
reboot

ja sinne meni, käy ja kukkuu

edit
olen näköjään ajanut tähän nyt tuotannossa olevaan 5.15 kerneliinkin talologgerin
muistaakseni siihen piti se python 2 ajaa

|  _ \ ___   ___| | ___ __ (_) | || |   / \
| |_) / _ \ / __| |/ / '_ \| | | || |_ / _ \
|  _ < (_) | (__|   <| |_) | | |__   _/ ___ \
|_| \_\___/ \___|_|\_\ .__/|_|    |_|/_/   \_\
                     |_|
Welcome to Armbian 22.08.8 Bullseye with Linux 5.15.76-rockchip64
« Viimeksi muokattu: 02.03.23 - klo:17:37 kirjoittanut jolla »

Poissa Ahwell

  • Nuorempi jäsen
  • **
  • Viestejä: 29
  • Maalämpöfoorumi
Vs: TalologgerPi:n uudestaanpystytys
« Vastaus #8 : 02.03.23 - klo:20:09 »
kokeilin raspilla (rpi4) eri softilla, siis valmiina saatavilla ja näyttää että 5.10 on vimonen mikä toimii ilman akrobatiaa ja sukanvaihtoja ja päälläseisomista
Linux raspberrypi 5.10.103-v7l+ #1529 SMP Tue Mar 8 12:24:00 GMT 2022 armv7l GNU/Linux
täältä
https://www.raspberrypi.com/software/operating-systems/

Raspberry Pi OS Lite (Legacy)
Release date: February 21st 2023
System: 32-bit

sudo su
apt update
apt upgrade
wget -O install_taloLoggerPi.py http://olammi.iki.fi/sw/taloLoggerPi/install_taloLoggerPi.py
chmod 755 install_taloLoggerPi.py
./install_taloLoggerPi.py
reboot

ja sinne meni, käy ja kukkuu

edit
olen näköjään ajanut tähän nyt tuotannossa olevaan 5.15 kerneliinkin talologgerin
muistaakseni siihen piti se python 2 ajaa

|  _ \ ___   ___| | ___ __ (_) | || |   / \
| |_) / _ \ / __| |/ / '_ \| | | || |_ / _ \
|  _ < (_) | (__|   <| |_) | | |__   _/ ___ \
|_| \_\___/ \___|_|\_\ .__/|_|    |_|/_/   \_\
                     |_|
Welcome to Armbian 22.08.8 Bullseye with Linux 5.15.76-rockchip64


Aivan mahtavaa!
Tarpeeksi kun hakkasi päätä seinään, sain homman pelittämään!

Kokeilin eri käyttiksillä Buster lite ja desktop... aina sama herja puutuvista paketeista.
Taisi olla kolmas setuppi + noilla sinun päivityksillä niin yhtäkkiä lähtikin asentamaan... eikä mitään hajua mistä johtui.

Iso käsi jokatapauksessa avusta. Omat taidot kun ei noin syvälliseen debuggaukseen riitä.


Vielä kaipaisin neuvoja miten tuon BU:n teon voisi parhaiten hoitaa?
Nyt setuppi siis ihan tavallisella kortilla, mutta käyn hakemassa pari endurance korttia, mitä olisi takoitus kuukausittain kopioida ja vuorotella.
Millä tuo image kannattaa siis tehdä? Edellisessä kombossa kortin kopiointi desktop appilla ei jostain syystä toiminut ja siksi tämä uudestaanpystytys kun kortti hajosi.
Pumppu: IVT HE E9, 300l käyttövesivaraaja, lämpimän käyttöveden kierto.
Kaivo: 210m.
Talo: 1000m3 kivitalo rv. 2002. Uusimaa.
IV: Vallox 145 MV
Kulutus 9MWh/a

Poissa jolla

  • Täysjäsen
  • ***
  • Viestejä: 131
  • Maalämpöfoorumi
    • mittauksia
Vs: TalologgerPi:n uudestaanpystytys
« Vastaus #9 : 03.03.23 - klo:09:26 »
vielä sevyydeksi että tämä versio ei kaipaa ainuttakaan muuta komentoa kun se puhtaana ajetaan
vain nuo 6 cmd käskyä, asennus scripti toimii virheettömästi juuri niinkuin pitääkin

Raspberry Pi OS Lite (Legacy)
Release date: February 21st 2023
System: 32-bit

sudo su
apt update
apt upgrade
wget -O install_taloLoggerPi.py http://olammi.iki.fi/sw/taloLoggerPi/install_taloLoggerPi.py
chmod 755 install_taloLoggerPi.py
./install_taloLoggerPi.py
reboot

uudempiin ja muihin versioihin joutuu vaihtelevasti kikkailemaan esmes python kakkosta yms

Poissa marko.

  • Täysjäsen
  • ***
  • Viestejä: 42
  • Maalämpöfoorumi
Vs: TalologgerPi:n uudestaanpystytys
« Vastaus #10 : 19.12.23 - klo:11:07 »
Mistä Linux raspberrypi 5.10.103-v7l+ voi ladata?

Tuolla on version 6.1 ja python taitaa olla V3
https://www.raspberrypi.com/software/operating-systems/

Raspberry Pi OS Lite
Release date: December 11th 2023
System: 32-bit
Kernel version: 6.1
Debian version: 12 (bookworm)
Size: 520MB
Show SHA256 file integrity hash:
Release notes


Toinen kysymys: Mistä näkee kernel version IMAGE filestä? (ilman että asentaa sen ensiksi?)



Poissa marko.

  • Täysjäsen
  • ***
  • Viestejä: 42
  • Maalämpöfoorumi
Vs: TalologgerPi:n uudestaanpystytys
« Vastaus #12 : 19.12.23 - klo:13:58 »
https://downloads.raspberrypi.org/raspbian_lite/images/

Tuolta uusin listalta
   raspbian_lite-2020-02-14/   2020-02-14 15:32   

Uname string: Linux version 4.19.97-v7+ (dom@buildbot) (gcc version 4.9.3 (crosstool-NG crosstool-ng-1.22.0-88-g8460611)) #1294 SMP Thu Jan 30 13:15:58 GMT 2020

Mutta täästä löytyy uudempiakin:

https://downloads.raspberrypi.org/raspios_oldstable_lite_armhf/images/raspios_oldstable_lite_armhf-2023-02-22/

 Linux version 5.10.103-v7+



kokeilin raspilla (rpi4) eri softilla, siis valmiina saatavilla ja näyttää että 5.10 on vimonen mikä toimii ilman akrobatiaa ja sukanvaihtoja ja päälläseisomista
Linux raspberrypi 5.10.103-v7l+ #1529 SMP Tue Mar 8 12:24:00 GMT 2022 armv7l GNU/Linux